User login

Vagrant box check update configuration error (resolved: upgrade Vagrant)

Vagrant box check update configuration error

The following settings don't exist: box_check_update

Commenting out this made it work fine:

# config.vm.box_check_update = true

But the better solution is to upgrade Vagrant.

The reason for the error is that Vagrant version 1.2.2, rather than 1.5 or 1.6, simply didn't know about that configuration setting, and complained, and quit.

Solution: Update your Vagrant. On Ubuntu or any Debian package managing system this is as easy as going to http://vagrantup.com/downloads and downloading the Linux (Deb) file. In a graphical interface you can just double-click this file, it will open the software updater and offer to upgrade your Vagrant. Do it and be happy!

Searched words: 
Vagrantfile box_check_update configuration error

Comments

Post new comment

The content of this field is kept private and will not be shown publicly.
  • You may post code using <code>...</code> (generic) or <?php ... ?> (highlighted PHP) tags.
  • You can use Markdown syntax to format and style the text. Also see Markdown Extra for tables, footnotes, and more.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Allowed HTML tags: <a> <em> <strong> <cite> <code> <ul> <ol> <li> <dl> <dt> <dd> <img> <blockquote> <small> <h2> <h3> <h4> <h5> <h6> <sub> <sup> <p> <br> <strike> <table> <tr> <td> <thead> <th> <tbody> <tt> <output>
  • Syntax highlight code surrounded by the {syntaxhighlighter SPEC}...{/syntaxhighlighter} tags, where SPEC is a Syntaxhighlighter options string or "class="OPTIONS" title="the title".
  • Lines and paragraphs break automatically.

More information about formatting options

By submitting this form, you accept the Mollom privacy policy.